$HOME not writeable error, but it is actually writable

I’m using Fedora 37. Installation from the rpm appears to go ok (but 32 new users seems excessive). Anyway, when attempting flox activate it says $HOME is not writable. That is not the case.

[0] stahnma@giga ~> rpm -qp flox.rpm
[0] stahnma@giga ~> flox -V
Version: 0.1.0-r339-0.0.10-r178
[0] stahnma@giga ~> flox activate

ERROR: $HOME directory '/home/stahnma' not writable ... aborting

[1] stahnma@giga ~> ls -al /home
total 0
drwxr-xr-x  3 root    root     0 Feb  1 21:39 .
dr-xr-xr-x. 1 root    root   212 Feb  1 21:45 ..
drwxr-xr-x  1 stahnma users 4.7K Feb  1 21:54 stahnma
[0] stahnma@giga ~>

The one thing I can think of is that $HOME is automounted (NFS) on this setup, so perhaps the method used to check if the directory is writable is unable to account for that in some way.

[0] stahnma@giga /home> flox -vv activate
`FLOX_PREVIEW_CONFIG_DIR` not set, using "/home/stahnma/.config/flox/"
no default user nix.conf found - weird
Attempting to read own UUID from file
`FLOX_PREVIEW_FEATURES_ENV` unset or not "rust", falling back to legacy flox
Running in flox with arguments: ["-vv", "activate"]

ERROR: $HOME directory '/home/stahnma' not writable ... aborting

Adding verbosity didn’t seem to shed a light on much.

Using strace, it’s certainly getting a EACCESS issue.

12017 [pid 38833] faccessat2(AT_FDCWD, "/home/stahnma", W_OK, AT_EACCESS) = -1 EACCES (Permission denied)

Note: selinux is completely disabled on this host.

Update: Moving $HOME to local disk instead of NFS automount, everything works fine, so confirming it was my hunch of /home on NFS.

Hi @Michael_Stahnke! Thank you for the detailed and clear report. :slight_smile: I have passed this on to our engineers to have a look.