Flox upgrade issue

This worked, thanks! Am I supposed to stay on the floxmain branch or should I go back to the x86_64-darwin.default branch I was on?

1 Like

Awesome! You can just leave it on floxmain

1 Like

The fix just rolled out to stable.flox.flox-prerelease. Thanks for finding that for us!


Thanks Matthew. I was able to upgrade to the prerelease version (r111) but I am actually not sure how I did it :-). I think I flox pull -e flox/prerelease and reactivated the environment, at first it didn’t work and eventually it did (maybe I did a hash -r in the meantime).

Now the conversion of both my default and my flox/prerelease environments worked ok and I can also edit them and see the nix format for the environment. I was even able to reintroduce my previous alias :-).

1 Like

About upgrading flox. I now did

flox list -e default

Removed my current flox version in default (it was r93), listed as 2 in the list:

flox rm 2 -e default

and installed the prerelease version with

flox install stable.flox.flox-prerelease -e default
1 Like