Losing part of my shell environment when using `flox develop`

Hi, I have observed this some time ago already and it is still present in the latest revision r86.

When I run flox develop on a project I lose part of my shell environment settings. For example my ~/.zshrc creates a bunch of aliases with source ~/.aliases but they are not available anymore when I run flox develop.

Is there anything I can do to help you diagnose this issue?


Me too. Digging deeper I’m also questioning the wisdom of Apple’s path_helper, source code here. I am strongly of the opinion that tools should be able to prepend or append to the PATH, but should not do that more than once (i.e. should detect when it has already modified the PATH) and reordering elements in the PATH to put their things first is distinctly out of line. That said, I’m not sure how to defend against this without doing the exact same thing. :frowning:

Sorry for the delay responding … let me look into this further and get back to you. Thanks.

Oh my! What a can of worms.

Hi Eric … you’ll be interested to hear that I’ve decided to fight fire with fire and implement a flox path “fixer” to remedy the [flox-specific] damage imposed by the Apple path “helper”. This feature is present in the version available in the flox/prerelease environment today, and should be included in the default installers and flox/default environment by the end of the day. :+1:

Hope this helps!

1 Like

Thanks Michael this indeed looks fine now!

1 Like