_FLOX_PUBLIC_KEYS() documented on Nix/Nixos tab of https://floxdev.com/docs/install-flox/

Is this a doc generation bug? That should look something like what’s shown in the Nix/Generic tab right? Something like flox-store-public-0:8c/B+kjIaQ+BloCmNkRUKwaVPFWkriSAd0JJvuDu4F0=

I’m trying to follow the instructions for installing flox with an existing nix installation and using the /nix/nixos tab.

When I run nix profile install --impure --accept-flake-config 'github:flox/floxpkgs#flox.fromCatalog' I see this output:

warning: ignoring untrusted substituter ‘https://cache.floxdev.com
warning: input ‘etc-profiles’ has an override for a non-existent input ‘flox-floxpkgs’
error: path ‘/nix/store/01y128174yij6ax2hlsk6mgp4l89fbb1-flox-0.2.5-r553’ does not exist and cannot be created

   … while evaluating 'getOutPath'

   at /nix/store/862iwi8xjvm368csqj6a41lmqdqwccb5-source/lib//mkFakeDerivation.nix:27:16:

       26|   # just build from source
       27|   getOutPath = outputName: let
         |                ^
       28|     stringOutPath = outputs.${outputName};

   … from call site

   at /nix/store/862iwi8xjvm368csqj6a41lmqdqwccb5-source/lib//mkFakeDerivation.nix:118:19:

      117|         inherit outputName;
      118|         outPath = getOutPath outputName;
         |                   ^
      119|       };

   … while evaluating the attribute 'derivations' of the derivation 'flox-0.2.5-r553'

   at /nix/store/862iwi8xjvm368csqj6a41lmqdqwccb5-source/lib//mkFakeDerivation.nix:133:7:

      132|     {
      133|       name = defaultOut.name;
         |       ^
      134|       system = eval.system;

@slimslenderslacks thanks for giving flox a try. I was able to verify this problem, and am looking into it now.

@slimslenderslacks it turns out we had a render error in our documentation

Where our docs give instruction for “Configure Substituters” please use these values

  nix.settings.extra-trusted-substituters = [ "https://cache.floxdev.com" ];
  nix.settings.extra-trusted-public-keys = [ "flox-store-public-0:8c/B+kjIaQ+BloCmNkRUKwaVPFWkriSAd0JJvuDu4F0="];

…in your configuration.nix

Then repeat sudo nixos-rebuild switch and the rest of the install instructions and let us know if this resolves the issue for you. Thanks again!

We did also update the docs with the correct information too. Install flox | flox:docs

Thanks for highlighting this issue.